1 VPF Importer User's Guide

Table of Contents for VPF Importer User's Guide

1.1 ABOUT THE VPF PRODUCT IMPORTER: VPF_IMP *

1.2 VPF_IMP TUTORIALS *

1.2.1 Browsing a VPF file. *

1.2.2 How to browse the LAT file of the DCW BROWSE Library: *

1.2.3 Creating an overlay file of area features. *

1.2.4 Creating an overlay file of line features. *

1.2.5 Creating an overlay file of point features. *

1.2.6 Creating an overlay file of text features. *

1.2.7 How to convert a MapInfo MIF file to NIMAMUSE Vec: *

1.3 MENU DESCRIPTION: *

1.4 WINDOWS/DIALOGS DESCRIPTION: *

1.5 SYSTEM REQUIREMENTS: *

1.6 FREQUENTLY ASKED QUESTIONS: *

1.7 KNOWN BUGS: *

 

 ____________________________

Related NIMAMUSE Documents


____________________________

1.1 ABOUT THE VPF PRODUCT IMPORTER: VPF_IMP

VPF_IMP is the NIMAMUSE program for interacting with NIMA's Vector Product Format (VPF) digital products. From VPF databases you can (1) create vector (VEC) files used in the FUSION program as overlays and (2) generate other formats that may be used to incorporate VPF data into and external program or commercial database. Also VPF_IMP can be used to output files that are generated by running data extraction queries on (VPF) data products such as:

1. Digital Chart of the World (DCW)

2. Digital Nautical Chart (DNC)

3. World Vector Shoreline (WVS)

4. Vector Smart Map Series (VMAP0 through 2)

5. Urban Vector Map (UVMAP)

6. Tactical Terrain Data (TTD)

7. Digital Flight Information Publication (DFLIP)

VPF_IMP is used to extract a dataset from a VPF product. The program limits the amount and type of data extracted by spatial extents and by thematic filtering. Spatial extents are expressed in decimal degrees of latitude and longitude that define the top, bottom, left, and right limits of the desired dataset. Allowing the user to select which Database, Library, Coverage and Feature Type to be retrieved for a given overlay file does thematic filtering. Additional thematic filtering may be done by creating a "Thematic Expression" that will allow the program to filter the data based upon the features attributes.

The end result of a data extraction session within VPF_IMP is either a "VEC" file that may be used as an overlay within the FUSION program or an ASCII file for external use.

1.2 VPF_IMP TUTORIALS

The following tutorial descriptions are written to be done on a DOS/WINDOWS platform using DOS/WINDOWS filename conventions. If you are running the tutorial on a platform other that a DOS/WINDOWS system you will need to adjust the filenames according to the conventions of your system.

1.2.1 Browsing a VPF file.

There are occasions when you may wish to see the contents of a VPF table or index in a textual format. It is for this reason that a browse capability was incorporated into the VPF_IMP program.

A copy of the DCW BROWSE Library is included on the NIMAMUSE CD to provide a sample VPF database to exercise the VPF_IMP application. It is located with the CD-ROM directory structure in the following diagram.

 

NIMAMUSE CD-ROM

|

|- DATA [directory]

| |

: |- DCW [directory]

| |

: |- BROWSE [directory]

|

|- DHT [file]

|- LAT [file]

|

|- etc.

:

1.2.2 How to browse the LAT file of the DCW BROWSE Library:

  1. Launch the VPF_IMP program from the NIMAMUSE Groupbox found in the Program Manager or from the executable file from within the File Manager.
  2. The VPF_IMP main window will appear with a top level menu.
  3. From the menu select "Options" menu item.
  4. Select "Browse Tables" item.
  5. An "Open File Dialog" will appear.
  6. Select the drive that corresponds to the CD-ROM drive for your system.
  7. Go to "\data\dcw" directory.
  8. Two files should appear in filename list: "dht" and "lat". Select the file named "dht".
  9. Select "OK".
  10. The Browse Settings dialog will appear showing the selected path and filename. By default the Header Data and Field Descriptions are selected to be viewed. The default setting for Starting Record is 1 and NR of Records is the total record count for the file (In this case 5). A string Length of 80 means that the display window text will be limited too not more than 80 characters per line. For this example accept all of the default settings.
  11. Select "OK".
  12. The program will now display the contents of the "lat" file in a text window.
  13. NOTE: The program is currently limited to displaying no more than the first 5000 lines of information. If the file that you select is a large file it may take the program quite a while to generate the text window.

  14. After the text window appears you be view the data by using the scroll bars along the right side and the bottom.
  15. The contents of the browse window may be printed if the windowing system on your computer is configured for printer support.
  16. To print the data select "File" from the main menu.
  17. Select "Print". The contents of the browse window should be printed at this time.
  18. When you are finished viewing the data the browse window is destroyed by closing it.

1.2.3 Creating an overlay file of area features.

In this exercise you will be instructed on how to create an overlay (.vec) file of land areas contained within North America.

  1. Launch the VPF_IMP program.
  2. Select "File" from the main menu.
  3. Select "Open" from the menu list.
  4. The Open File Dialog will appear.
  5. Select the CD-ROM drive.
  6. Go to "\data\dcw" directory.
  7. Two files should appear in filename list: "dht" and "lat".
  8. Select the file named "dht".
  9. Push the "OK" button.
  10. The VPF Query Editor window will appear. The current database path and name (i.e. "e:\data\dcw") will be listed at the top.
  11. In the Libraries listbox the "BROWSE" library name will appear. If the selected database contained more that one library all available libraries would be listed for you to choose from.
  12. In the "Coverage" listbox all the available coverages are listed. Select the "PO: Political/Oceans" coverage.
  13. In the "Feature Class" listbox all available feature classes are listed. We will use the default "POAREA.AFT" class that stands for Political/Ocean Areas.
  14. Push the "Where Clause" button.
  15. The thematic expression "Where [ID:Row Identifier] [=] [0]" will appear as the default expression.
  16. From the first listbox select "POPYTYPE:Land or water feature". The expression will then change to read "where [POPYTYPE:Land or water feature] [=] [1:Land areas]"
  17. The geographic extents "Geo extents" by default show the limits of the currently selected library, in this case the Browse library extents are:
  18. N = 90

    W = -180

    E = 180

    S = -90

  19. For the northern extent of our area to be extracted enter:
  20. "90.0" in the North (upper) textedit box.

    "-150.0" in the West (left) textedit box.

    "0.0" in the South (lower) textedit box.

    "-60.0" in the East (right) textedit box.

  21. Select the option "Save extents to INI" to store the coordinates for future use.
  22. To initiate the retrieval process push the "Retrieve Feature" button.
  23.  

  24. The "Status Window" will appear showing:
    1. start time
    2. the current time
    3. a running count of how many features have been found.
  25. When the program has complete the search the Features Extracted Dialog will appear stating that 128 features were extracted.
  26. Push the "OK" button.
  27. The Symbology Dialog will appear. This allows you to define the default display settings on how you want the data to be drawn when used as an overly with the FUSION program.
  28. Select "Green" from the Area Color listbox.
  29. Leave the Fill Pattern set to "Solid".
  30. Activate the "Display Edges" option. The default settings are black one-pixel wide edges.
  31. Push the "Done" button. Now when you display the data that you just extracted in FUSION it will appear as green polygons with a black border.
  32. The Save File Dialog will appear.
  33. 30. Go the desired drive and directory in which you wish to save the data.
  34. Enter "land.vec" in the filename text edit box.
  35. Push the "OK" button.
  36. The data is now saved as a .vec overlay.
  37. The program returns to the "VPF Query Editor" window to permit processing of additional queries.
  38. To end this query session select the "File" menu item.
  39. Select "Exit" menulist item.
  40. This ends tutorial 2. To view the overlay land.vec" refer to the FUSION program documentation on displaying .vec files as overlays.

1.2.4 Creating an overlay file of line features.

In this exercise you will be instructed on how to create an overlay (.vec) file of drainage line features (rivers) contained within North America.

  1. Launch the VPF_IMP program.
  2. Select "File" from the main menu.
  3. Select "Open" from the menu list.
  4. The Open File Dialog will appear.
  5. Select the CD-ROM drive.
  6. Go to "\data\dcw" directory.
  7. Two files should appear in filename list: "dht" and "lat".
  8. Select the file named "dht".
  9. Push the "OK" button.
  10. The VPF Query Editor window will appear. The current database path and name (i.e. "e:\data\dcw") will be listed at the top.
  11. In the Libraries listbox the "BROWSE" library name will appear. If the selected database contained more that one library all available libraries would be listed for you to choose from.
  12. In the "Coverage" listbox all the available coverages are listed. Select the "DN: Drainage" coverage.
  13. In the "Feature Class" listbox all available feature classes are listed. We will use the default "DNLINE.LFT" class that stands for Drainage Line Features.
  14. The geographic extents "Geo extents" by default show the limits of the currently selected library, in this case the Browse library extents are:
  15. N = 90

    W = -180

    E = 180

    S = -90

  16. If you have completed tutorial NR. 1 the geographic extents are saved in the MUSE.INI file. To retrieve the saved values select the option "Get extents from INI". Otherwise, use the following geographic extents:
  17. N = 90

    W = -150

    E = -60

    S = 0

  18. To initiate the retrieval process push the "Retrieve Feature" button.
  19. The "Status Window" will appear showing:
  20. (1) start time

    (2) the current time

    (3) a running count of how many features have been found.

  21. When the program has complete the search the Features Extracted Dialog will appear stating that 69 features were extracted.
  22. Push the "OK" button.
  23. The Symbology Dialog will appear. This allows you to define the default display settings on how you want the data to be drawn when used as an overly with the FUSION program.
  24. Select "Blue" from the Line Color listbox.
  25. Leave the Line Type set to "Solid".
  26. Push the "Done" button. Now when you display the data that you just extracted in FUSION the rivers will appear as solid blue lines.
  27. The Save File Dialog will appear.
  28. Go the desired drive and directory in which you wish to save the data.
  29. Enter "rivers.vec" in the filename text edit box.
  30. Push the "OK" button.
  31. The data is now saved as a .vec overlay.
  32. The program returns to the "VPF Query Editor" window to permit processing of additional queries.
  33. To end this query session select the "File" menu item.
  34. Select "Exit" menulist item.
  35. This ends tutorial 3. To view the overlay "rivers.vec" refer to the FUSION program documentation on displaying .vec files as overlays.

1.2.5 Creating an overlay file of point features.

In this exercise you will be instructed on how to create an overlay (.vec) file of populated places point features (cities) contained within North America.

  1. Launch the VPF_IMP program.
  2. Select "File" from the main menu.
  3. Select "Open" from the menu list.
  4. The Open File Dialog will appear.
  5. Select the CD-ROM drive.
  6. Go to "\data\dcw" directory.
  7. Two files should appear in filename list: "dht" and "lat".
  8. Select the file named "dht".
  9. Push the "OK" button.
  10. The VPF Query Editor window will appear. The current database path and name (i.e. "e:\data\dcw") will be listed at the top.
  11. In the Libraries listbox the "BROWSE" library name will appear. If the selected database contained more that one library all available libraries would be listed for you to choose from.
  12. In the "Coverage" listbox all the available coverages are listed. Select the "PP: Populated Places" coverage.
  13. In the "Feature Class" listbox all available feature classes are listed. We will use the default "PPPOINT.PFT" class that stands for Populated Places Point Features.
  14. The geographic extents "Geo extents" by default show the limits of the currently selected library, in this case the Browse library extents are:
  15. N = 90

    W = -180

    E = 180

    S = -90

  16. If you have completed tutorial NR 1 the geographic extents are saved in the MUSE.INI file. To retrieve the saved values select the option "Get extents from INI". Otherwise, use the following geographic extents:
  17. N = 90

    W = -150

    E = -60

    S = 0

  18. To initiate the retrieval process push the "Retrieve Feature" button.
  19. The "Status Window" will appear showing:
    1. start time
    2. the current time
    3. a running count of how many features have been found.
  1. When the program has complete the search the Features Extracted Dialog will appear stating that 58 features were extracted.
  2. Push the "OK" button.
  3. The Symbology Dialog will appear. This allows you to define the default display settings on how you want the data to be drawn when used as an overlay with the FUSION program.
  4. Select "Yellow" from the Marker Color listbox.
  5. Select "Asterisk" from Marker Type listbox.
  6. Push the "Done" button. Now when you display the data that you just extracted in FUSION the cities will appear as yellow asterisks.
  7. The Save File Dialog will appear.
  8. 25. Go the desired drive and directory in which you wish to save the data.
  9. Enter "cities.vec" in the filename text edit box.
  10. Push the "OK" button.
  11. The data is now saved as a .vec overlay.
  12. The program returns to the "VPF Query Editor" window to permit processing of additional queries.
  13. To end this query session select the "File" menu item.
  14. Select "Exit" menulist item.
  15. This ends tutorial 4. To view the overlay "cities.vec" refer to the FUSION program documentation on displaying .vec files as overlays.

1.2.6 Creating an overlay file of text features.

In this exercise you will be instructed on how to create an overlay (.vec) file of political/ocean text features contained within North America.

  1. Launch the VPF_IMP program.
  2. Select "File" from the main menu.
  3. Select "Open" from the menu list.
  4. The Open File Dialog will appear.
  5. Select the CD-ROM drive.
  6. Go to "\data\dcw" directory.
  7. Two files should appear in filename list: "dht" and "lat".
  8. Select the file named "dht".
  9. Push the "OK" button.
  10. The VPF Query Editor window will appear. The current database path and name (i.e. "e:\data\dcw") will be listed at the top.
  11. In the Libraries listbox the "BROWSE" library name will appear. If the selected database contained more that one library all available libraries would be listed for you to choose from.
  12. In the "Coverage" listbox all the available coverages are listed. Select the "PO: Political/Oceans" coverage.
  13. In the "Feature Class" listbox all available feature classes are listed. Select the "POTEXT.TFT" class, which stands for Political/Ocean Text Features.
  14. The geographic extents "Geo extents" by default show the limits of the currently selected library, in this case the Browse library extents are:
  15. N = 90

    W = -180

    E = 180

    S = -90

  16. If you have completed tutorial NR 1 the geographic extents are saved in the MUSE.INI file. To retrieve the saved values select the option "Get extents from INI". Otherwise, use the following geographic extents:
  17. N = 90

    W = -150

    E = -60

    S = 0

  18. To initiate the retrieval process push the "Retrieve Feature" button.
  19. The "Status Window" will appear showing:
    1. start time
    2. the current time
    3. a running count of how many features have been found.
  1. When the program has complete the search the Features Extracted Dialog will appear stating that 22 features were extracted.
  2. Push the "OK" button.
  3. The Symbology Dialog will appear. This allows you to define the default display settings on how you want the data to be drawn when used as an overlay with the FUSION program. For this example we will accept the default values.
  4. Push the "Done" button. Now when you display the data that you just extracted in FUSION the text will appear as black letters.
  5. The Save File Dialog will appear.
  6. 23. Go the desired drive and directory in which you wish to save the data.
  7. Enter "text.vec" in the filename text edit box.
  8. Push the "OK" button.
  9. The data is now saved as a .vec overlay.
  10. The program returns to the "VPF Query Editor" window to permit processing of additional queries.
  11. To end this query session select the "File" menu item.
  12. Select "Exit" menulist item.
  13. This ends tutorial 5. To view the overlay "text.vec" refer to the FUSION program documentation on displaying .vec files as overlays.

1.2.7 How to convert a MapInfo MIF file to NIMAMUSE Vec:

  1. Launch the VPF_IMP program from the NIMAMUSE Groupbox found in the Program Manager or from the executable file from within the File Manager.
  2. The VPF_IMP main window will appear with a top level menu.
  3. From the menu select "Options" menu item.
  4. Select "Convert to NIMAMUSE Vec" item.
  5. Select "MapInfo MIF"
  6. An "Open File Dialog" will appear.
  7. Select the MIF file
  8. Select "OK".
  9. The Save File Dialog will appear.
  10. 10. Move to the desired drive and directory in which you wish to save the data.
  11. Enter "mif.vec" in the filename text edit box.
  12. Push the "OK" button.
  13. The data is now saved as a .vec overlay.

1.3 MENU DESCRIPTION:

File:

New:

Unused.

Open:

Used to open the Query Edit Dialog.

Save:

Unused.

Save as:

Unused.

Print:

Used to print the contents of a Text Browse Window.

Printer Setup:

Used to configure the current printer.

Exit:

Used to exit the program.

Edit:

Unused.

Fonts:

Used to select font type and size for Text Browse Windows.

Options:

Browse tables:

Used to open the File Open Dialog in order to select which VPF file to view in a text format.

Convert to NIMAMUSE Vec:

Used to convert the desired format to NIMAMUSE Vec format.

NIMAMUSE ASCII:

A generic text format to provide a mechanism to incorporate vector data into external databases, GIS's, and vector graphics systems.

MapInfo MIF:

The commercial GIS MapInfo ASCII MIF file output.

Output Format:

Used to select the desired format to save the output data in.

NIMAMUSE Vec:

A NIMAMUSE internal binary format used by the FUSION program as a drawing list for building overlays.

NIMAMUSE ASCII:

A generic format to provide a mechanism to incorporate vector data into external databases, GIS's, and vector graphics systems.

OPC:

A format for OPCPLOT, Oceanographic Charting Software for the World's Seas, by NOAA Center for Coastal Ecosystem Health, Charleston, SC, USA.

Simple Vector Format:

The commercial GIS MapInfo ASCII MIF file output.

Arc/Info Ungenerate:

The commercial GIS ARC/Info Ungenerate ASCII file output.

Arcview Shapefile:

The commercial GIS ArcView Shapefile output.

VRML:

The Virtual Reality Modeling Language file output.

DXF:

The Drawing Exchange Format file output.

Windows:

Used to list the available Text Browse Windows.

Help:

Used to open the XVT Help Dialog.

 

1.4 WINDOWS/DIALOGS DESCRIPTION:

All window/dialog descriptions are base upon the DOS/Windows implementation, their appearance on other systems will be somewhat different but the fields will be consistent.

This is the main window to extract VPF data for display purposes.

1. Database: Shows path and name of current VPF database.

2. Library: Listbox of valid libraries.

3. Coverage: Listbox of valid coverages.

4. Feature Class: Listbox of valid feature class names.

5. Geo Extents: Defines the geographic limits (in decimal degrees) of the area to be extracted.

a. Upper textedit box: Northern limit.

b. Left textedit box: Western limit.

c. Right textedit box: Eastern limit.

d. Lower textedit box: Southern limit.

6. Where clause: Up to two clauses may be generated.

a. Left listbox: Feature attribute name.

b. Middle listbox: Attribute operator.

c. Right listedit box: Attribute value.

7. Retrieve Features Pushbutton: Starts the retrieval of the features based upon geo extents and thematic description.

8. Where Clause Pushbutton: Initiates up to two where clauses.

9. Cancel Where Pushbutton: Removes the most recent where clause. If two clauses are active the second clause is eliminated first, and then the first clause is eliminated.

10. Close Pushbutton: Closes the query editor and "disconnects" from the current VPF database.

11. Help Pushbutton: Invokes the Help dialogue for the current window.

This dialog permits you to define how you wish to format the contents of the textual data you want to browse.

1. Table: Lists the path and name of the selected file.

2. Show Header Data checkbox: Lists the contents of the table header when checked.

3. Show Field Descriptions checkbox: Lists the descriptions of each field within the table when checked.

4. Show Field Labels: Unused at present.

5. Starting Record textedit: The record number of the first record to be listed (default = 1).

6. NR of Records textedit: the number of records to be listed starting with the record nr listed in the Starting Record textedit. (default = total record count of the selected table.)

7. String Length textedit: set the length of the text line in the Browse Window and printed pages. (Default = 80).

 

Open File Dialog: The standard Open File Dialog for your system. It is used in this program to point the location of the VPF database.

Save File Dialog: The standard Save File Dialog for system. It is used in this program to determine where and under what filename to save selected datasets.

This window keep's you informed as to what the VPF_IMP program is doing. Some import operations may take several minutes to perform and without the Status Window you wouldn't know if the program is working correctly or just hung up.

1. Top line: Describes the current activity and time that the retrieval began.

2. Bottom line: Displays a running count of the number of features found and the current time.

3. Cancel Pushbutton: Cancels the retrieval process and returns the features already found.

Here you can define the characteristics of how you want the selected point, line, area, and text features rendered when it is displayed in FUSION.

  1. Point Symbol: Shows the list of available point symbols.
  2. Color Symbol: Shows the list of available colors.
  3. Line Symbol: Shows the list of available line styles.
  4. Area Symbol: Lists the area styles (i.e. solid, hollow, striped, etc.).
  5. Text Symbol: Lists the font styles.
  6. OK pushbutton: Loads the symbology selection into the data structure and initiates the save data function.
  7. Add CGM: Allows the addition of CGM symbols.
  8. Cancel pushbutton: Closes the symbology window and disposes of the retrieved features.
  9. Help pushbutton: Brings up the help dialog.

1.5

SYSTEM REQUIREMENTS:

The NIMAMUSE standards enable this software to run on many systems. It has been tested on the systems meeting the following minimum requirements:

80386 processor with math coprocessor

8 Mb RAM

CD-ROM reader

Microsoft Windows 3.1 with WIN 32s or Windows 95/NT.

25 MB free disk storage

16 Mb RAM

CD-ROM reader

70 Mb free disk storage

SunOS 4.1.3 or Solaris 2.X

16 Mb RAM

CD-ROM reader

70 Mb free disk storage

HP-UX 9.0.1 or greater

16 Mb RAM

CD-ROM reader

70 Mb free disk storage

IRIX 5.2 or greater

1.6 FREQUENTLY ASKED QUESTIONS:

1.7 KNOWN BUGS:

 

---------------------------------------------






Related NIMAMUSE Documents


Datum Transformation and Coordinate Conversion 4, DTCC4    DTCC4.DOC

DTCC4 Users Guide    DTCC4_UG.DOC

Perspective Scene    PSCENE.DOC

Perspective Scene Application Reference    PSC_UG.DOC

Line of Sight    LOS.DOC

Line of Sight Application Reference    LOS_UG.DOC

VPFView   VPFVIEW.DOC

VPFView User's Guide    VPFV_UG.DOC

Raster Importer   RAST_IMP.DOC

Raster Importer Users Guide   RAST_UG.DOC

Vector Importer   VPF_IMP.DOC

Fusion   FUSION.DOC

Fusion Users Guide   FUS_UG.DOC

Access and Prepare NIMA Digital Data   APNDD.DOC

Build Your Own Map   BYOM.DOC

Run Specialty Applications   RSA.DOC

NIMAMUSE 2.1 Documentation   INTRO.DOC